gemellocattivo.com

Which means "Evil Twin". Lets see your projects where you change boring into fun or create the fun from scratch.
It is currently Mon Nov 19, 2018 5:52 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 13 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Sun Oct 11, 2015 11:23 am 
Offline

Joined: Thu Jan 01, 2015 6:47 pm
Posts: 2241
So I had the ECU powered up a while ago but today figured out how to load the firmware and connected to ELconsole....nice!

Next I need to feed it some signals and see how everything works. There is an internal function to generate crank and cam signals that I have setup so in theory if I jumper that back the crank/cam inputs the ECU should think it's running an engine and should be spitting out fuel and spark signals....that test is next.


Top
 Profile Send private message  
 
PostPosted: Sun Oct 11, 2015 3:45 pm 
Offline

Joined: Sat Jan 03, 2015 5:40 am
Posts: 161
You probably already know about the JimStim simulator board that the Megasquirters use? It can simulate a number of crank configurations, but AFAIK it doesn't do a cam output.

I use it and a Ford EDIS setup for testing my COP ignitions


Top
 Profile Send private message  
 
PostPosted: Mon Oct 12, 2015 8:36 am 
Offline

Joined: Thu Jan 01, 2015 6:47 pm
Posts: 2241
cribbj wrote:
You probably already know about the JimStim simulator board that the Megasquirters use? It can simulate a number of crank configurations, but AFAIK it doesn't do a cam output.

I use it and a Ford EDIS setup for testing my COP ignitions


I have one somewhere...and I think it will do the cam signal???.....I might have lent out though...hmmmm

But, one of the available enginelab functions is a crank/cam generator:
http://enginelab.net/support_tree.php?f ... _Generator

Its got about 30 different crank/cam pattern options and you can assign them to any of the output channels and then put a control on the user screen to set the test RPM. Hopefully I can just jumper the signals...but it might need a pull up on it, I'll find out soon enough.

What I think I'm missing though that the JimStim has is a bunch of 0-5V pots.....but the analog inputs have an adjustable filter so I guess I could put a high speed PWM and pull-up on a few of the outputs and set the filter to smooth it out and see what happens. That would give control of everything in the simulation right from the user screen which is nice.


Attachments:
Engine generator1.JPG
Engine generator1.JPG [ 96.46 KiB | Viewed 1429 times ]
Engine generator2.JPG
Engine generator2.JPG [ 107.74 KiB | Viewed 1429 times ]
Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group